Vik Booking Configuration

Questions and Answers about the configuration of Vik Booking.
Read the public conversations or open a new Support Ticket for help (active Support License required).

Open New Support Ticket - Post a Message

Sign up or Sign in to post a message

Tomasz 12-4-13 10:44
Hi, I have a problem when using special prices. I want make a special price for 26 December 2013 to 10 January 2014.

First when i save this , the date change to 10 January 2013, and even i tried again change and save , it's still change to 2013.

I try also other dates for example , with year 2015 or other , still the same problem, always change to 2013.

Is this is a bug or special prices are valid only for current year ??

Thanks in advance
Best regards,

Tomasz

Comment this post


Sign up or Sign in to post a message

Staff E4j 12-4-13 11:43
Hi,

Special Prices are not tied to the year, a Special Price from the 26th of December to the 10th of January will be applied even on 2014, 2015 etc.. It is just the administrator section that reports the current year but if you try to make a search in the front site, you will see that the Special Price is being applied to your rooms.
Flymo 12-3-13 11:31
Hi again, Almost completed setting up of the Template Booking and Vik Booking.
When I make a test booking, the client receives a confirmation email for the booking, but the admin "does not" how do I setup so that both the Client and the Admin get a confirmation email of the booking? Thanks Paul

Comment this post


Sign up or Sign in to post a message

Flymo 12-3-13 14:29
Yes I agree, I have tried a number of different options, and email addresses, and it sends out to the Customer Email Address ok, but not to the admin. I have replied to the customer email which should go back to the admin email address, and that is received ok in the admin mailbox.
Flymo 12-3-13 14:35
additional info, the hosting platform is Linux, using Joomla 3.1 hosting platform requires authenticated smtp with Port 587 no additional security, have turned off spam filters.
Rafael Rebollo Alonso 12-3-13 14:57
If you are using an administrator email address with the same domain name (www.yourdomain.com, email@yourdomain.com) maybe you administraror emails are not routed correctly out of the server. The customer emails are sent because they are not using the same domain. This happened to me on a dedicated server with Plesk control panel. Try using a different email (google, hotmail,...) for the administrator.
Flymo 12-3-13 15:03
Thanks Rafael, I was starting to think the same as you, that email was not being routed. I am using Hsphere/Parallel's CP. I just tested a booking and setting the customer email to the same as the admin email and that email came thru to the Admin Mailbox ok
Rafael Rebollo Alonso 12-3-13 15:06
Maybe this link could help you:
http://www.serveridol.com/2011/03/16/disabling-email-service-for-a-domain-in-plesk/
Flymo 12-3-13 15:09
thanks again Rafael, yes I agree, I will try some different email options and mail servers and see what happens, but I do think like you this is the cause. Many thanks Paul
View all comments (9)
Marcos 11-28-13 17:56
Hello,
Our website was configured in 2 languages: Spanish and English.
We have been working with the translations files and Falang files
However, we would like to know how to translate the categories and room description.
Should we use Falang?
Should we modify any specific file?

Thanks in advance
Best regards,

marcos

Comment this post


Sign up or Sign in to post a message

Staff E4j 11-28-13 18:28
Hello,
Contents that are saved in the database like the names and the descriptions of your rooms or the names of the categories, cannot be translated through the .ini language files and the native Joomla functions, you need to use a third party extension like Falang. All the translations so have to be created from the administrator section of Falang but you need to upload the content elements xml files first or Falang won't know what has to be translated.
For more details please have a look at the Documentations page, there's an article under the section Translations that explains where you have to upload the xml content elements files.
http://www.extensionsforjoomla.com/documentations.html
Lukas Ponikowski 11-27-13 23:42
Hello,

please visit http://bit.ly/IkqIPc. I can't figure out why the forwarding to the paypal payment site isn't working. Instead you get redirected to the order overwiew. Any ideas?

Lukas

Comment this post


Sign up or Sign in to post a message

Staff E4j 11-27-13 23:55
Hello,

Please check the settings of the payment method PayPal from the administrator section. The setting "Auto-Set Order to Confirmed" must be disabled because the payment response needs to be validated.
That setting should be turned ON only for those payment methods that don't require to validate any payment response.
Wladimir Muriel 11-22-13 00:34
Hello:

I have problems with the list room view please se the link
http://www.urdesahotel.com/index.php/habitaciones
I cant see the price and the details buttom
help me please

Wladimir

Comment this post


Sign up or Sign in to post a message

Staff E4j 11-22-13 00:51
Hi,

That is just a CSS conflict with your Template. The div containing the Cost and the Details button should be moved a little up by changing the CSS rule "bottom: -28px;" into a higher value.
I suggest you to use a tool like Firebug for browser Firefox or the Inspector of Google Chrome and Safari to see what CSS rules are being applied and at which lines.
Gustavo Diaz 11-21-13 23:21
Yesterday I have installed VikBooking at the site hotelparadorcancun.com and I have (so far) two small problems.
1) Is not possible for me update the company logo at Configuration/Company and Orders. Do not upload my image.
2) I need the site to work in spanish language. I have instaled the es-ES... files at the rigth folders (for fontend and administration) but the component remains workin in english.
Please, hep me to solve this little problems.

Comment this post


Sign up or Sign in to post a message

Staff E4j 11-21-13 23:54
Hi,

If you have problems uploading your logo from the Configuration of VikBooking then you should check the permissions of the following folders and sub-folders:
/administrator/components/com_vikbooking/
/components/com_vikbooking/
The program uses the native Joomla functions for uploading images so it has to be a permissions problem that you can fix with your ftp client.

About translating the program into Spanish, your Joomla should have the Spanish language installed and enabled and you should have the .ini language files in the folders /administrator/language/es-ES/ and /language/es-ES/
If you don't have the Joomla Language Switcher Module published then the default language will be loaded.
Gustavo Diaz 11-22-13 00:18
Thanks for your quickly and precise answer.
The point 1 (logo) is solved, but the point 2 is not.
The Joomla site and administration area are configured to Spanish language.
When I have tried change the language files of en-GB directory by the renamed es-ES files, the component do not show the legend, show the variable names.
I'm using the traslated files of your repository (the version that include front end and administration area files) but, I do not know why, do not work.
Thanks again for your help.
Staff E4j 11-22-13 00:40
If you are seeing the variables of the .ini language file then the Spanish translation file should be in the right folder (/language/es-ES/es-ES.com_vikbooking.ini).
Usually when the definitions are not translated it is because Joomla is unable to find the .ini language file or because the syntax of the .ini file is wrong.
We don't always check if the translations uploaded by our clients are valid but I hope the file just lost the encoding after being zipped, uploaded and downloaded. You should try to open the file es-ES.com_vikbooking.ini with a good text editor (I suggest Notepad++ for Windows and TextMate for Mac) and save it with a proper encoding. You should also make sure that the file doesn't have a syntax error like a non-closed double quote at the end of a line but I'm hoping it's just an encoding problem otherwise it would mean that the file uploaded had errors.
Domainire 11-21-13 02:22
Hi,

After we setup booking extension, and want to text reservation. This is all I'm getting "No rooms are available for booking for 6 (or other numbers or) Nights."
Any fix to this?

Thanks,

Comment this post


Sign up or Sign in to post a message

Staff E4j 11-21-13 13:09
Hi,

Make sure you have at least one Type of Price and that you have entered some cost per night in the Rates Table task of the administrator section. If you are looking for a room for 6 nights and you don't have a cost in the Rates Table for 6 nights then you will get that message because there are no results.
Also, make sure the number of Adults and Children of your rooms matches the search that you did.
Costantino Chiefari 11-19-13 20:38
Hi, first of all thanks for your wonderfull piece of sw, than little problem. I installed the new version of VikBooking but from that moment the system doesn't send anymore confirmation email to customers, only to admin. If i push again the "resend email" button in the "order" section, i get the answer back from the system "order email sent to" but without customer email address and the email is not sent, i tried also "jutility" flag but its the same.
Vikbooking is installed on joomla 2.5

Any suggestions?
pls, help!!
Thanks
Costa

Comment this post


Sign up or Sign in to post a message

Staff E4j 11-19-13 21:29
Hi,
The problem must be related to the setting "Send Order eMails with JUtility" that needs to be enabled with your server configuration. Some configuration settings are saved in the php session so you are probably using the old method. Enable that setting and try to make a new reservation with a different browser where the php session will be new and the Configuration will be updated to the new settings. Your other browser will see the new Configuration settings after the php session gets renewed so after around 15 minutes of inactivity.
Costantino Chiefari 11-19-13 22:01
Nothing to do. I changed computer and i made a new reservation and the broser replay "email address recipient missing"
It seems that the system is not anymore able to recognize the customer email.....
Staff E4j 11-19-13 22:19
Okay then you should check the Custom Fields from the administrator section. There must be at least one published and required field that is flagged as "is eMail".
Rob Jones 11-12-13 21:26
Hi, I just installed the new version of VikBooking - thanks for the added features! I am having a weird problem, though. I've been making some changes to the vikbooking_smartphone.css file to make the booking pages display like I want on a mobile phone and that is working fine, but now the desktop version of the site is using the mobile CSS! In other words, when I view the site on a desktop computer, I'm seeing the mobile CSS. Very strange! Can you suggest a way to correct that?

Comment this post


Sign up or Sign in to post a message

Staff E4j 11-12-13 21:55
Hi,
That is really strange and I think your desktop is just viewing a cached version of the CSS.
The file vikbooking_smartphones.css is loaded only in case the user agent detected is a smart phone while the file vikbooking_tablets.css is loaded only in case of tablets.
The main CSS file vikbooking_styles.css instead is always loaded but the other files are appended to the head of the page so every class can be re-defined in the files for smart phones or tablets. Desktop browsers will never have those CSS files loaded, I don't know why you were seeing the rules for mobile devices. You should look at the source code of the web page with your desktop browser and those CSS files should not be there.
Rob Jones 11-12-13 22:21
Yes, it is very strange! I did some more testing and it only seems to be happening in Safari. Firefox and Chrome are working normally. I looked at the page source in Safari, and the mobile CSS file is being loaded. I checked to make the User Agent wasn't set to a mobile device and it is not.
Staff E4j 11-12-13 22:48
Okay, we will investigate more even though the detector has been tested with Safari for desktops and Safari for iPhone and iPad.
We will release a patch and notify everyone in case we find something to be changed.
Rob Jones 11-12-13 22:51
OK, sounds good. Thanks!
Rob Jones 10-7-13 13:55
My client is very happy with Vik Booking - Thanks for a great product! We are using this to book Motorhome campsites, and we hit one snag that we can't figure out how to fix: If somebody wants to book more than 15 mights, there is a special pricing and procedure, so they must call to make their reservation over the phone.

Is there a way to have a message say "Monthly rates may apply. Please call Fair Harbor RV at 478-988-8844 to book your reservation." if somebody tries to book more than 15 nights?

Comment this post


Sign up or Sign in to post a message

Staff E4j 10-7-13 14:03
Hi,
In the Rates Table you should not create rates for more than 15 nights. This way the users that are searching for more nights will receive a message that says something like "no rooms are available for booking for xx nights".
You can change that message from the .ini language file saying that "Monthly rates may apply. Please call Fair Harbor RV...."
Rob Jones 10-7-13 14:23
Ah, That should work great. I edited the language file to say what I wanted it to. Thanks!

Extensionsforjoomla.com is not affiliated with or endorsed by the Joomla!® Project or Open Source Matters.
The Joomla!® name and logo is used under a limited license granted by Open Source Matters the trademark holder in the United States and other countries.
E4J s.r.l. - VAT N. 06794860483

This site uses cookies. By continuing to browse you accept their use. Further information