e4j's Blog news about the Joomla!® world and the Vik extensions

VikAppointments 1.7.2

VikAppointments 1.7.2 is now available.
This version contains some new features, several enhancements and a few bug fixes.

What's in 1.7.2?

Here is a list of what this new version brings.

New Features

  • Introduced a tool to customize the main colors of the plugin with a live preview.
  • Improved the SEO for the internal media manager, which now provides the possibility to specify titles, alt(s) and captions.
  • Added a parameter to choose whether the customers are allowed to edit a custom field after the first booking.

Improvements

  • Added a button to get the directions to the appointment address through the pre-installed maps software (Apple Maps, Android Maps or Google Maps).
  • It is now possible to download backup archives in case the source folder is placed above the root.
  • The backup system now includes the styles defined through the customizer of VikAppointments.

Bug Fixes

  • Adjusted some permissions for the Employees Area, which were not considered in certain cases.
  • Fixed a bug that was considering any customer as subscribed.
  • Fixed the error that could occur while trying to create/update a custom field.
  • Fixed an issue that might not show Google Maps with certain templates.
  • Fixed a few PHP warnings that could occur when the login was required before accessing the availability calendars.
  • The refunded status code is no more mandatory.
  • Fixed an issue with the file filter while fetching the available e-mail custom texts.

IMPORTANT NOTE: update VikAppointments before the modules, otherwise you might face a fatal error. Once VikAppointments has been properly updated to the latest 1.7.2 version, try to visit the dashboard of the program, where you should see a message like the following one:

The structure of the installed modules has changed. Now you MUST update them all from the Joomla updates section!

At this point you can visit the Joomla! updates section and install the latest version of all the listed modules.

Got Errors During the Update?

If the update process gave you some errors, then it may be possible that your current installation or account are not allowed to install the new version of VikAppointments for free. This is may due to 2 different factors:

  • the domain from which you are requesting the update is not registered;
  • your support license expired.

In case you are sure that your website is properly registered on our system, then you may have to purchase the updater of VikAppointments in order to extend your support license by another year. Click HERE if you wish to go ahead with the purchase.

Otherwise just contact us if you don't know what you should do.

Enjoy your new VikAppointments!

Do you work also with WordPress?

Did you know that some of our Joomla!® extensions are also available as plugins for WordPress?

Please visit our dedicated marketplace VikWP.com for more details!

Visit vikwp.com

Extensionsforjoomla.com is not affiliated with or endorsed by the Joomla!® Project or Open Source Matters.
The Joomla!® name and logo is used under a limited license granted by Open Source Matters the trademark holder in the United States and other countries.
E4J s.r.l. - VAT N. 06794860483

This site uses cookies. By continuing to browse you accept their use. Further information